Putty expected key exchange group packet from server

» »


Как исправить ошибку expected key exchange group packet from server в Putty?

Для того, что бы putty подружился с ubuntu 18.04 или debian 9 и новее без ошибки expected key exchange group packet from server
Нужно в настройках putty изменить алгоритм генерации ключей.

Теперь при подключении в окне Putty нужно выбирать в настройках SSH => "Key exchange" группу "diffie-hellman-group14", которая использует более длинный ключ из 2048 бит.
В русской версии в настройках SSH => Обмен ключами выберите diffie-hellman-group14 и продвиньте её в самый вверх кнопкой Вверх

Это связано с тем, что старый алгоритм признан не безопасным и сервер его не принимает, поэтому putty не может подключиться.


Друзья! Приглашаем вас к обсуждению. Если у вас есть своё мнение, напишите нам в комментарии.